This topic contains 1 reply, has 2 voices, and was last updated by Sofia Moss Sofia Moss 2 years, 1 month ago.

Location Service Not Enabled – "Share My Location" option doesn't work

  • Hi,

    I had created a topic in regards to a few mobile issues experienced with the plugin just a few days ago, but for some reason that post is no longer accessible on the forum. Below is a copy of the response I received when I asked why if I’m viewing the map (on iPhone) and choose not to enable location services, the black notification bar appears and displays the message “Location service not enabled. Continue Anyway | Share my Location”, but if “Share My location” is clicked nothing happens. This was the response:

    “We’ve tested your link https://beckonicecream.com/store-locator/ using multiple iPhone devices including iPhone 6,7 and X and it seems that the geolocation is working fine.

    The reason that when you click the Share my location link, it doesn’t do anything is because, this button function is made at browser level and when you press Don’t allow at the beginning, it disables your geo location service at phone setting level. Similar to when clicking the Geo location icon, if geo location is being blocked by the device, this button will not be clickable or usable until the settings is re-enabled. Therefore, you will need to re-enable the geolocation setting at phone level, more details available at this link here.”

    However, I’m realizing now that that option for “Share my location” in the notification bar doesn’t even work on a browser-level setting; if I visit my page “https://beckonicecream.com/store-locator/” on a desktop (Macbook Pro using Google Chrome) and get that notification message and click the “Share my Location” link in the notification bar, nothing happens. Can you help resolve this issue – shouldn’t this link reload the page or enable the geolocation service? Or is there a way to hide the “Continue Anyway” and “Share My Location” options entirely (but keep the line “Location service not enabled”?

    Sofia Moss
    StaffSuper ContributorUser Level

    Hi there,

    Thanks for the details, apologize on the confusion, we’ve checked with our devs team, the function is actually not able to override browser location setting which is due to security reasons. You can remove the link by editing wp-content/plugins/superstorefinder-wp/js/mega-superstorefinder.js and search below code:

    1. Search and change from:

    map.status.$label.append('|');

    to:

    map.status.$label.append('');

    2. Search and remove code below:

    jQuery('<a href="#/" class="inline-space-left inline-space-right">'+ssfShareLocation+'</a>')
    
    .appendTo(map.status.$label)
    
    .on('click', function(e) {
    
    e.preventDefault();
    
    geolocator.watch();
    
    });

    Save and upload the file, clear cache and refresh the page.

    Cheers,
    Sofia

The topic ‘Location Service Not Enabled – "Share My Location" option doesn't work’ is closed to new replies.